linux-surface/pkg/arch/kernel/PKGBUILD
2024-03-09 21:13:56 +01:00

266 lines
8.4 KiB
Bash

# Maintainer: Maximilian Luz <m@mxnluz.io>
# Maintainer: Blaž Hrastnik <blaz@mxxn.io>
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
pkgbase=linux-surface
pkgver=6.7.9.arch1
pkgrel=1
pkgdesc='Linux'
_shortver=${pkgver%.*}
_fullver=${pkgver%.*}-${pkgver##*.}
_srctag=v${_fullver}
url="https://github.com/archlinux/linux/commits/$_srctag"
arch=(x86_64)
license=(GPL2)
makedepends=(
bc
cpio
gettext
git
libelf
perl
tar
xz
python
# we don't need `pahole` as deps because we disable `CONFIG_DEBUG_INFO`
# ignoring deps for docs because we don't build docs package
)
optdepends=('iptsd: Touchscreen support'
'linux-firmware: Firmware files for Linux'
'linux-firmware-marvell: Firmware files for Marvell WiFi / Bluetooth')
options=('!strip')
_srcname=archlinux-linux
source=(
"$_srcname::git+https://github.com/archlinux/linux#tag=$_srctag"
config # the main kernel config file
surface.config # surface specific options
arch.config # config changes for linux-surface kernel
0001-surface3-oemb.patch
0002-mwifiex.patch
0003-ath10k.patch
0004-ipts.patch
0005-ithc.patch
0006-surface-sam.patch
0007-surface-sam-over-hid.patch
0008-surface-button.patch
0009-surface-typecover.patch
0010-surface-shutdown.patch
0011-surface-gpe.patch
0012-cameras.patch
0013-amd-gpio.patch
0014-rtc.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
'04143712e593d45a597661fe00f89cf92d52c62df3468c68a46c952c2ef4db64'
'985cd5e0b11538f31887e451c398d226c06ca4b34c5466e93a21ebd65b7b3919'
'3cabe391cc39dbee88a79f76e9e7a68f7fbcd5518941aa2ab73a77692c87dead'
'c25dbc1fd9e9ab89816028b0dc3609b7e92b8594a41fc5efd43a94b1dc8f8ee9'
'b11b9570685ef86dc37b360160ceed0beaa5c89058e76b762847cfd4eb9a3845'
'a1991ce5bbeb0f8264765b1c5a5e3fd63d0c6a2fca18210fd271c7b1ac73c23d'
'29481c8493b3ecff2411e1deab01c0bf7157394d1de66a6e8aeba2d0632af310'
'52d2ce6dc1b73c8560b3a3e9fb10aaa431e9b8c5a339d0fac9cdc2c913b5f1c6'
'77fa032c4f1a7fdb586555942cc092242234816fb13dca3f19d78921a301e8cb'
'aad7b3c7444f0dea9897be211b6f5eb9b4803e093d9861ecf4908f005868dd8f'
'c5e064f7ed6b87e56176f3c76562d7dfdb8ebf20d8c3697c2836d12a895b92eb'
'0133be1b8e7cdd56222f3cba67277fac2bdd03722dd52d381c85f0df49f758ff'
'f6e42e4000c107ec83f81a77cb204ef4a981f88f627c69306a3c09578060248d'
'3fffa7d359fa26bcd4d8829de68ae29a6f0774a9e475d2834004f8476278d73c'
'7734390fe83b1e8a975972bd6d74f32d11b6bddb17a751ce3a0ec069661b4ab8'
'0058f94ac4a4ed17d4abd1f871113ffbd2b81123b6b7047b3e719951389a968d'
'a2a8f120a77c95879036f8a9048756b9daa82e24eff3b919bf4ceae0f60f6fa2')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
# optional certificate and key for secure boot signing
_mok_crt="$PWD/MOK.crt"
_mok_key="$PWD/MOK.key"
_make() {
test -s version
make KERNELRELEASE="$(<version)" "$@"
}
prepare() {
cd $_srcname
echo "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
make defconfig
make -s kernelrelease > version
make mrproper
# setup git
git config --local user.email "surfacebot@users.noreply.github.com"
git config --local user.name "surfacebot"
local src
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
git am -3 "../$src"
done
echo "Setting config..."
# cp ../config .config
# merge the two configs together
./scripts/kconfig/merge_config.sh -m ../config ../surface.config ../arch.config
_make olddefconfig
echo "Prepared $pkgbase version $(<version)"
}
build() {
cd $_srcname
_make all
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(
coreutils
initramfs
kmod
)
optdepends=(
'wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
)
provides=(
linux=${_shortver}
KSMBD-MODULE
VIRTUALBOX-GUEST-MODULES
WIREGUARD-MODULE
)
replaces=(
virtualbox-guest-modules-arch
wireguard-arch
)
cd $_srcname
local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
local image_name="$(_make -s image_name)"
# sign boot image if the prequisites are available
if [[ -f "$_mok_crt" ]] && [[ -f "$_mok_key" ]] && [[ -x "$(command -v sbsign)" ]]; then
echo "Signing boot image..."
sbsign --key "$_mok_key" --cert "$_mok_crt" --output "$image_name" "$image_name"
fi
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$image_name" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
_make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/build
}
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=(pahole)
provides=("linux-headers=${_shortver}")
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
# required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
# http://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
# http://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
# https://bugs.archlinux.org/task/71392
install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
echo "Removing $(basename "$arch")"
rm -r "$arch"
done
echo "Removing documentation..."
rm -r "$builddir/Documentation"
echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
echo "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -bi "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
strip -v $STRIP_STATIC "$file" ;;
application/x-executable\;*) # Binaries
strip -v $STRIP_BINARIES "$file" ;;
application/x-pie-executable\;*) # Relocatable binaries
strip -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
echo "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")
_package${_p#$pkgbase}
}"
done
# vim:set ts=8 sts=2 sw=2 et: