linux-surface/pkg/arch/kernel/PKGBUILD
2023-12-08 18:00:37 +01:00

266 lines
8.4 KiB
Bash

# Maintainer: Maximilian Luz <m@mxnluz.io>
# Maintainer: Blaž Hrastnik <blaz@mxxn.io>
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
pkgbase=linux-surface
pkgver=6.6.4.arch1
pkgrel=1
pkgdesc='Linux'
_shortver=${pkgver%.*}
_fullver=${pkgver%.*}-${pkgver##*.}
_srctag=v${_fullver}
url="https://github.com/archlinux/linux/commits/$_srctag"
arch=(x86_64)
license=(GPL2)
makedepends=(
bc
cpio
gettext
git
libelf
perl
tar
xz
python
# we don't need `pahole` as deps because we disable `CONFIG_DEBUG_INFO`
# ignoring deps for docs because we don't build docs package
)
optdepends=('iptsd: Touchscreen support'
'linux-firmware: Firmware files for Linux'
'linux-firmware-marvell: Firmware files for Marvell WiFi / Bluetooth')
options=('!strip')
_srcname=archlinux-linux
source=(
"$_srcname::git+https://github.com/archlinux/linux#tag=$_srctag"
config # the main kernel config file
surface.config # surface specific options
arch.config # config changes for linux-surface kernel
0001-surface3-oemb.patch
0002-mwifiex.patch
0003-ath10k.patch
0004-ipts.patch
0005-ithc.patch
0006-surface-sam.patch
0007-surface-sam-over-hid.patch
0008-surface-button.patch
0009-surface-typecover.patch
0010-surface-shutdown.patch
0011-surface-gpe.patch
0012-cameras.patch
0013-amd-gpio.patch
0014-rtc.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
'bdfd2629b1fe907b9270fc540adaa51ff526cbd361b23aba38c4c5fce7f5397b'
'7b14b09a99e8a3f224bff4f95650406d34f51d81b527c0f1dfe17a54ba69346c'
'3cabe391cc39dbee88a79f76e9e7a68f7fbcd5518941aa2ab73a77692c87dead'
'5c9162aa9a1e2c8670029ef7f6ad9a198d7cd4106a0fdad98a51e3d302f191a0'
'b04b4bad99ed83b27b16bee94864d381991aa8b58972c433d3d2cec73c42ebfd'
'edd7f39d0e42aa9774ef25fd8e02d427c8e350c48b265b3759b7acdfb4207e11'
'd1d8bfc6734f2723b6777638b9537e0186a1a376461b08d8fbf4deff622a9d8f'
'c197adf243774efdb62f39888c176f48dc9537d38ca225145103c46c20465721'
'450a071b2e7b5d97ce8f51145ac9868582c191e2f88502ee85a621578f781160'
'd8bcce50921784c8e548c0b5dea13b27ae6470d4261d87c4cefe7962c8fdee49'
'1941788ac1be036b19e035dccf69a912399d56caf9e68798a8f0c562c045db48'
'89fbbedd4aba05ba143fb0d6f935b1942747be46ca2c4d108daaf0cfb053f76d'
'13a881b67512e84f121304cc32bf823c77c4002837bb4d8b278adadf67f52b77'
'e93e2ab5be2adab1ee226b9586b0aeae51afaec4ce4daeb9e2827a87c4bfae72'
'd66ca97942253e497ad74dc710cfe5eb1670cd5ac2d0d112a9acec03a9cd8da5'
'45f97db10bc35cbc4d139fcdba2a68f80e0c59b84ab1cd0171b724f23651f6c7'
'9d941440b4108b25d3995e8c933058cdd044bf6087d0e6147fed40b693c93e31')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
# optional certificate and key for secure boot signing
_mok_crt="$PWD/MOK.crt"
_mok_key="$PWD/MOK.key"
_make() {
test -s version
make KERNELRELEASE="$(<version)" "$@"
}
prepare() {
cd $_srcname
echo "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
make defconfig
make -s kernelrelease > version
make mrproper
# setup git
git config --local user.email "surfacebot@users.noreply.github.com"
git config --local user.name "surfacebot"
local src
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
git am -3 "../$src"
done
echo "Setting config..."
# cp ../config .config
# merge the two configs together
./scripts/kconfig/merge_config.sh -m ../config ../surface.config ../arch.config
_make olddefconfig
echo "Prepared $pkgbase version $(<version)"
}
build() {
cd $_srcname
_make all
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(
coreutils
initramfs
kmod
)
optdepends=(
'wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
)
provides=(
linux=${_shortver}
KSMBD-MODULE
VIRTUALBOX-GUEST-MODULES
WIREGUARD-MODULE
)
replaces=(
virtualbox-guest-modules-arch
wireguard-arch
)
cd $_srcname
local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
local image_name="$(_make -s image_name)"
# sign boot image if the prequisites are available
if [[ -f "$_mok_crt" ]] && [[ -f "$_mok_key" ]] && [[ -x "$(command -v sbsign)" ]]; then
echo "Signing boot image..."
sbsign --key "$_mok_key" --cert "$_mok_crt" --output "$image_name" "$image_name"
fi
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$image_name" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
_make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/build
}
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=(pahole)
provides=("linux-headers=${_shortver}")
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
# required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
# http://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
# http://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
# https://bugs.archlinux.org/task/71392
install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
echo "Removing $(basename "$arch")"
rm -r "$arch"
done
echo "Removing documentation..."
rm -r "$builddir/Documentation"
echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
echo "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -bi "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
strip -v $STRIP_STATIC "$file" ;;
application/x-executable\;*) # Binaries
strip -v $STRIP_BINARIES "$file" ;;
application/x-pie-executable\;*) # Relocatable binaries
strip -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
echo "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")
_package${_p#$pkgbase}
}"
done
# vim:set ts=8 sts=2 sw=2 et: